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Quick-start Guide for YRDKRX63N v3.3 
 

Dear Customer, 
 

Thank you for purchasing the Renesas Demonstration Kit for the RX63N MCU, Version 3.3. 
 

Please begin by reading this document throughout. 
Please go to http://am.renesas.com/RDKRX63NDVD to download the complete installer package.  This will allow you to 
take full advantage of the tools (IDEs, compilers, third-party software) mentioned in this document. 

 
RDK Validation 

 

Before we do anything else, let’s verify the board is working when you receive it. 
 

NOTE: To perform this validation, your kit must be running the 'Factory Demo' (which it is when you purchase it). If you 
need to reload the factory demo, refer to Chapter 9 in the User’s Manual. 

 

NOTE: If you connect the kit to your computer, you will probably be asked to install the driver. At this time, ignore that 
request. We will install the software and driver after validation. 

 

1.   On the RDK, ensure the MCU Mode DIP switch, SW5, is set to “DEBUG” (OFF, OFF, OFF, ON) 
as shown on the right. 

 
2.   Connect one end of the included USB cable to your computer and the other end to the J-

Link connector of the RDK. If still present from the factory, remove the protective peel off 
the LCD by pulling on the red tab. 

 

• The J-Link connector is located above the display between the DB9 connector for the serial port and the power jack. 
 

• This is the debug interface but, for now, we are only using it to power the board. Ignore any “Driver not found” errors – 
we will install the driver for the debugger in the next section. 

 
3.   Press the “RESET” button, SW4. 

 
4.   You should see the RDK 'Welcome' screen and version number on the LCD screen 

(for about 5 seconds). 
 

5.   Tilt the board and observe changes to the “Roll” and “Pitch” variables at the bottom of the screen. 
Turn the potentiometer VR1 and observe changes to the “Pot” variable at the bottom of the screen. 

 
Software Download and Installation 

 

We recommend you download the latest installer package located at http://am.renesas.com/RDKRX63NDVD  
 

NOTE: You may have to accept the installation of drivers that are not digitally signed. Click on “Install this driver software 
anyway” if this message appears. 

 

NOTE: Be aware that if you choose to install ALL available software, the full installation could take over an hour. (By default, 
we selected what you will need to quickly get started.) 

 

6.   Open your favorite browser and surf to http://am.renesas.com/RDKRX63NDVD. 
 

7.   Download the files to your hard drive; extract all the content to your computer.   
 
8.  Locate the file “Autorun.exe” in the root and double click on this file to start installation. Follow the on-screen directions to 

install the required software. We recommend installing Renesas e2 studio, Renesas RX Toolchain, Segger J-Link, and the 
Micrium Demo. These are selected by default.  
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General Information 

 

For basic operation, the RDKRX63N only needs USB power; the Aux Power Jack J4 (+5V regulated input) is only 
necessary in high-current operation. 

 

The install package contains the following components (note that only the Renesas software is pre-selected by 
default. If you require additional software, re-run the installer and select additional tools): 

 

a. Renesas e2 studio (IDE) 
 

b. HEW (High Performance Embedded Workshop) (IDE) 
 

c. RX Tool Chain (C/C++ compiler, assembler, and linker, with demonstration projects) 
 

d. GNU Tool Chain (C/C++ compiler, assembler, linker) 
 

e. IAR Embedded Workbench (IDE with C/C++ compiler, assembler, and linker) 
 

f. Segger J-Link OB Debugger and drivers. 
 

g. Third-party ports for RDK from Micrium, Segger, CMX, and Rowebots. 
 

h. Documentation (Start > Renesas > YRDKRX63N): Schematics, Gerber files, RDKRX63N User 
Manual, RDKRX63N Quick-start Guide. 

 
Connection 

 

Once you connect the board, the “Found New Hardware” Wizard may appear. Please follow the steps below 
to install the drivers. Note that administrator privileges are required for Windows® 2000/XP/Vista/Win7 
machines. 

Windows® 2000/XP 
 

a. Select option ‘No, not this time’ in “Found New 
Hardware” Wizard dialog, and click <Next> button. 

 

b. Verify the “Recommended” option is selected and 
click <Next>. 

 

c. If using Windows XP, go to step ‘e’; otherwise, 
click <Next>. 

 

d. Click <Next> to install the driver. 
 

e. Click <Finish> to close the wizard. 

Windows  Vista / Windows  7 (32 or 64) 
 

a. Select “Locate and install driver software (recommended).” 
 

b. “User Account Control” dialog box will appear. If applicable, 
enter administrator password and click <OK>. 

 

c. Driver installation will start. After couple of minutes, a 
“Windows security” dialog box will appear. Select “install this 
driver software anyway.” 

 

d. “Device driver software installed successfully” pop-up will 
appear in the windows toolbar and installation will complete. 

 
Factory Demo in Memory 

 

Please check the hardware version of your board; it should show 

 

 
v33 

 
 
at the top right corner of the PCB.

 
Please check the software version displayed on the LCD; it should show “ver 3.2.” If you have an older version or if you just 
completed the e2 studio IDE evaluation, please upgrade the RX63N firmware to version v3.2 of the factory demo: 

 
1)   Locate the RDK’s User Manual on the install package directory: YRDKRX63N_User_Manual_32_R20UT2532EU0100.pdf 

 
2)   Open the user manual and jump to Chapter #9: Restoring the Factory Demo 

 
3)   Follow the instructions using the e2 studio environment, which will guide you to restore the factory demo. 

 
Getting Started on the Demos 

 

Now that your board is programmed with the correct firmware (V3.2), the following three demonstrations can be performed: 
 

Renesas e2 studio  IDE Page 3 

Micrium’s µC/Probe demo* 
(make sure ‘Micrium Demo’ was selected during the DVD installation) 

 
Pages 4 & 5 

Exosite Cloud demo* Pages 6 - 9 

* This Quick-start Guide gets you started with the YRDKRX63N using the RX ToolChain in Renesas e2 studio. These example projects do not use an RTOS. See the 
“Exosite Cloud Demo” starting on Page 7 for RTOS examples from Micrium and Exosite. 
Please continue to the demonstration that is right for you. Of course, we recommend you do all three. 
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Getting Started with e2 studio 
 

e2 studio  Workspace  and Demonstration Projects 
Renesas e2 studio (pronounced e-squared studio) is an Eclipse-based integrated development 
environment. 

1. Launch “Renesas  e2studio” from the Start Menu (All Programs > Renesas Electronics 
e2studio > Renesas e2studio). 

2. In the “Workspace Launcher” dialog box, browse to the following location for your sample 
project workspace: “C:\Workspace\YRDKRX63N” 

3. If the toolchain integration dialog box pops up, select all available toolchains and click 
4. “Register.” 
5. Close the Welcome window.  If you want to re-open this later to explore the e2 studio tutorials, it 

is located under Help > Welcome. 
6. You should see an empty workspace.  To import the demo projects, navigate to File > Import. 
7. Under the “General” folder, select “Existing projects into workspace.”  Click “Next.” 
8. On the next page, choose “Select archive file:” and browse to 

“C:\Workspace\YRDKRX63N\RDK_Demos.zip” (see image to the right).  Click “Finish.” 
9. Chose any project, for example, ADC_OneShot project.  Right click on the project folder and select 

“Close Unrelated Projects.”  You can re-open any of these projects later by selecting the project in 
the project explorer and navigating to Project > Open Project from the top menu bar. 

10. There are instructions detailing how to use this project in the “adc_oneshot_demo_main.c” file in 
the “src” folder. 

11. From the top menu bar, select “Project”, then “Build all” (Ctrl+B). The “Build All” builds all open projects in 
the workspace and may take over a minute. 

12. The build is successful if you see “Build complete” in the console window at the bottom of the screen. 
 

Connect to the Renesas Demonstration Kit 
13. Make sure the RDK is connected to your PC as outlined in Steps 1 and 2. 
14. Highlight the project you are working on and select Run > Debug Configurations or use the shortcut shown to the right. 
15. Select the “ADC_OneShot.x” debug configuration under “Renesas GDB Hardware Debugging” and click “Debug.” 

Also accept any possible warning(s) about selecting a n other target than J-Link or incorrect register programming. 
16. If you are asked to switch to the debug perspective, click “Yes.”  You can switch back to the 

C/C++ perspective using the tabs in the upper right corner.    
17. To run the code, click the “Resume icon”. 

18. Click the “Suspend” icon  to stop code execution. e2studio will display the source code at the current program counter. 
19. When you are finished, click “Terminate”  to disconnect. 

 
Next Steps 
After you have completed this procedure, please review the code in the example projects that came with the kit. These labs and example projects will help you 
understand the device and development process using Renesas Development Tools. 

 
You may also be interested in the following additional content available on your DVD.  To evaluate any of these products, launch the installer again and select a 
product from the installer menu.  You will be directed to relevant documentation when the installer is done. 
�  Segger embOS RX* – Sample projects demonstrating the Segger RTOS 
�  Micrium Demo* – Sample project demonstrating the Micrium RTOS and networking solution 
�  KPIT GNU RX – Free unlimited toolchain based on the GNU compiler collection (GCC).  This compiler can be integrated with e2 studio and HEW. 
�  IAR Embedded Workbench for Renesas RX – IAR combined IDE/toolchain for the Renesas RX family. 
�  CMX-Micronet and CMX-RTX* – Sample projects demonstrating the CMX networking solution and RTOS 
�  RoweBots Unison RTOS* – Sample projects demonstrating the Rowebots Unison RTOS, networking, file system, and USB solutions 
�  Renesas Flash Programmer – Flash programming tool 
�  Tera Term – Several of our demo projects require a terminal emulator.  Install Tera Term if you do not already have a terminal program installed. 
* Requires Renesas High-performance Embedded Workshop (HEW), an earlier IDE from Renesas. We recommend e2 studio for new development. 

 
To learn more on how to use e2 studio, use the help documentation within e2 studio located under Help > Help Contents. 

 
Compiler/Linker Limitations 
The demonstration code is built using the Renesas compiler.  This compiler is fully functional, but time limited. You have 60 days to evaluate the full product 
before the compiler will limit the linker to 128k bytes (this limit includes both Flash and SRAM output from the linker). Fully licensed RX compiler versions are 
available from your Renesas supplier. 

 
Support 
Support Forums for this RDK:   www.RenesasRulz.com 
Online training for RX and other products and tools is available at:   www.RenesasInteractive.com 
Website for this RDK:  www.renesas.com/rdkRX63N 

 
Technical Support Email Addresses: 

America:    techsupport.america@renesas.com    //    Europe:    tools.support.eu@renesas.com    //  Japan:    csc@renesas.com 
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Controlling and Monitoring the Renesas YRDKRX63N with µC/Probe™ 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

          
 

  
 

 
 

     
 

 
    

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
For more information, visit Micrium.com/probe
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Exosite Demo – Introduction and Instructions 
 
 
 

Renesas RX63N RDK offers a quick and easy way to run powerful factory demos, as this kit comes 
pre-programmed. We highlight the Ethernet capability of the RX63N and for best demonstrations, require 
access to a LAN access point. Any Ethernet 10/100M connection at home or at the office will work fine 
as long as it supports DHCP server. (Some administrators ONLY allow company MAC addresses through 
their network. If you have networking problems, this could be the cause.). 

 

The RDK is pre-installed with factory code that enables the following 3 demos. To run either one, review 
the switch combination in the following tables: 

 
 

#1 Exosite Cloud Demo / Micrium’s TCP/IP 
 

Default demo at power-up (don’t press any switch) 
 

#2 µC/Probe 3.1 over J-Link (JTAG) 
 

Default demo at power-up (don’t press any switch) 
 

#3 µC/Probe 3.1 over TCP/IP 
 

Press/Hold Switch 1  then release it once the welcome screen clears 
 

Here is the list of requirements to interact with each demo: 
 

 

Setup requirements for each demo 
 

Hardware 
 

Software 
 

Internet connection 
 

#1 Exosite Cloud Demo 
 

PC, Smartphone + LAN 
 

Any Web Browser 
 

YES 
 

#2 Micrium’s IP connectivity & µC/Probe 3.1 
 

PC, Laptop +  LAN 
 

µC/Probe 3.1 SW 
 

NO (intranet) 

 
 

STEP 1: Exosite Cloud Demo 
 

Make sure DIP Switch #5 is set to Debug Mode (OFF, OFF, OFF, ON), then connect the Ethernet 
Plug J1 to the LAN and power-on the RDK board via USB or external power. At this point, the 
factory demo v3.2 should boot up. If not, please re-flash the factory demo as described on Page 
#2. The Welcome screen should be displayed, and the board will try to acquire its IP address. Wait 
until the IP address is displayed at the top of the screen. Here are the similar messages to expect: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

STEP 2: Register and Start the Exosite client in your browser 
 

Register for a free Renesas RDK Users account:   visit   https://renesas.exosite.com/pricing   and 
 

click on:                                 (Renesas and Exosite are providing this evaluation site free of charge). 

Once registered, log-in with your new account at https://renesas.exosite.com/login 

V1.0 (March 2015) Page 6 R01PF0076EU0303_RX63N 
 

http://https/renesas.exosite.com/pricing
http://https/renesas.exosite.com/pricing
https://renesas.exosite.com/login
https://renesas.exosite.com/login


YRDKRX63N v3.3 
Quick-start Guide 

 

 

 
Exosite Demo – Introduction and Instructions 

 
 

STEP 3: Enter your Portal Dashboard 
 

You should then see the Community Portal and be able to view your own dashboard:  

 
 

STEP 4:  Add your RDK as a new device to your dashboard 
 

In your dashboard, find the Getting Started Window. Click on the word here in 
 

“Click here to add your RDK.” Alternately, you can add a new device by clicking on Devices in the left 
column and click on + Add Device in the upper right corner of the screen. This will take you to the board 
selection menu; use the pull-down menu to select YRDKRX63N-V3.2, then click on Continue. 

 

 
 

STEP 5: Identify your kit with its MAC address on the Cloud 

Read off your board (either from the board sticker or from the 2nd line of the LCD) the MAC 
 

address of your module. Expect a number starting with “00:30:55:08: xx:xx.” Enter it in the device MAC 

address field by adding the last 4 digits (2 bytes). Enter a significant name and location for your RDK and 

click on Continue. 
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Exosite Demo – Introduction and Instructions 

 
 

STEP 6:  Receive confirmation of the proper registration on the Exosite Portal 
 

Upon completion of registration in Step #5, the server should return a message of you having successfully 

enabled your RDK for the Exosite portal operation and should return an authentication key called “Client 

Interface Key” or CIK. This key guarantees that your RDK is a unique client on the Exosite Cloud. 

Your screen should report the following message: 

Your YRDKRX63N-V3.2 device was successfully enabled with the CIK. 

Congratulations, your RDK is now activated for Cloud operations. Click on QUIT to exit this menu. Then 

perform a warm reboot of your kit pressing the RESET key (SW4). After a while, the board should 
report a new status as “Cloud:  Connected”  on the LCD, underneath the Exosite section. 

 
 

STEP 7:  Bring up the “Portal Dashboard” for your kit 
 

Upon completion of Step #6, you may start your evaluation of the Cloud-connected RDK, regardless of the 

physical location of the board. The user may dial into that RDK from any location as long as an 

Internet connection and an HTML-based web browser are available, including the use of Laptop PC, 

Smartphone and any other internet-connect web browser. 
 
 

Please click on the shortcut available in the Exosite Portal. A typical dashboard has been created in advance 

for each connected device, so your RDK will be accessible via a preset dashboard, called “portal 

dashboard”. 
 

Please click on the following box to launch this Portal Dashboard in the top left-hand menu: 
 

 
 

On the Dashboards page, identify the dashboard associated with your kit (YRDKRX63N-V3.2) and 

click on the corresponding URL link: 
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Exosite Demo – Introduction and Instructions 

 
 

STEP 8:  Interact with your Cloud-connected kit using a preset dashboard 
At this point, you should be able to see the preset dashboard for your RDK, and it should look like this: 

 

 
 

Go ahead and dial new input to the potentiometer, the temp sensor and the LED control button and witness the 
changes in the portal dashboard; response time may vary from several seconds to several tens of a second based on 
the network performance. 

 
In Steps #1 through #8, you learned how to perform sensor reading and to set the LED status from the Exosite portal 
through the Cloud. 

 
Congratulations! 

 
 
 

For additional information on Micrium’s Firmware demos, µC/Probe, RTOS and TCP/IP services, visit: 
http://micrium.com/ 

 

For additional information on Exosite Cloud, visit www.exosite.com and renesas.exosite.com 
 

For information on RX63N demos, development tools, MCU libraries, application support or additional demo 
packages, visit http://www.renesas.com/ 

 

For technical support check www.RenesasRulz.com 
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Disclaimer 
 
By using this Renesas Demonstration Kit (RDK), the user accepts the following terms. The RDK is not guaranteed to be error free, and the User assumes the entire 
risk as to the results and performance of the RDK. The RDK is provided by Renesas on an “as is” basis without warranty of any kind whether express or implied, 
including but not limited to the implied warranties of satisfactory quality, fitness for a particular purpose, title and non-infringement of intellectual property rights with 
regard to the RDK. Renesas expressly disclaims all such warranties. Renesas or its affiliates shall in no event be liable for any loss of profit, loss of data, loss of 
contract, loss of business, damage to reputation or goodwill, any economic loss, any reprogramming or recall costs (whether the foregoing losses are direct or indirect) 
nor shall Renesas or its affiliates be liable for any other direct or indirect special, incidental or consequential damages arising out of or in relation to the use of this RDK, 
even if Renesas or its affiliates have been advised of the possibility of such damages.  
Precautions 
This Renesas Demonstration Kit is only intended for use in a laboratory environment under ambient temperature and humidity conditions. A safe separation distance 
should be used between this and any sensitive equipment. Its use outside the laboratory, classroom, study area or similar such area invalidates conformity with the 
protection requirements of the Electromagnetic Compatibility Directive and could lead to prosecution. 
The product generates, uses, and can radiate radio frequency energy and may cause harmful interference to radio communications. However, there is no guarantee 
that interference will not occur in a particular installation. If this equipment causes harmful interference to radio or television reception, which can be determined by 
turning the equipment off or on, you are encouraged to try to correct the interference by one or more of the following measures: 
Ensure attached cables do not lie across the equipment  
Reorient the receiving antenna  
Increase the distance between the equipment and the receiver  
Connect the equipment into an outlet on a circuit different from that which the receiver is connected  
Power down the equipment when not in use  
Consult the dealer or an experienced radio/TV technician for help NOTE: It is recommended that wherever possible shielded interface cables should be used.  
The product is potentially susceptible to certain EMC phenomena. To mitigate against them it is recommended that the following measures be undertaken:  
The user is advised that mobile phones should not be used within 10m of the product when in use.  
The user is advised to take ESD precautions when handling the equipment.  

The Renesas Demonstration Kit does not represent an ideal reference design for an end product and does not fulfill the regulatory standards for an 
end product. 
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